ny

Сбойное обновление KB4480970 для Windows server 2008 R2 от 08.01.2019

08.01.2019 Microsoft выпустило обновление за номером KB4480970, способное приводить к проблемам:
- невозможно подключится к серверу по RDS через не ненативных клиентов (пример: remmina);
- клиенты (Windows 10) не могут покдлючится к общим ресурсам сервера, возникает ошибка "Invalid Handle" (Неверный дескриптор).

Решение: удалить обновление и перезагрузиться.

Ссылка: https://windowsreport.com/invalid-handle-error/

Восстановить доступ к MS SQL Server

Бывает, что иногда теряются права доступа к СУБД MS SQL Server.

Есть как минимум два способа получить административный доступ обратно (требуют права администратора в ОС):
1. Запустить СУБД в single  user mode, добавить пользователя, добавить его в группу sysadmin, запустить сервер в обычном режиме.
Пример:
net stop MSSQLSERVER
net start MSSQLSERVER /m
sqlcmd
CREATE LOGIN superadmin WITH PASSWORD = 'MyP@ssw0rd'
go
sp_addsrvrolemember 'superadmin', 'sysadmin'
go

2. Запустить, например, Management Studio с правами System с помощью psexec. В этом случае остановка сервера не требуется.
Пример:
psexec -s -i "C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\Ssms.exe"

.

Сброс пароля у пользователей СУБД Caché

Внезапно одна мумия перестала размахивать бинтами. Выглядит она как некоторое ПО, написанное для СУБД Caché. Куда и кем ни ткнись - всюду "Access Denied".
Как и многие другие СУБД, Caché имеет болт с левой резьбой однопользовательским режим.

Включается он так: ccontrol start <инстанс> Emegencyid=<пользователь>,<пароль>.
Под заданными учетными данными ломимся в портал и устраиваем там беспредел.

SQL Server 2014 - EventID 17311 (fatal exception c0000005)

Жила-была мумия одного SQL Server 2014(12.0.5557.0). Бежала мимо уборщица, шваброй махнула сервер упал и как давай по-полу валяться.

Проблема
После аппаратного сбоя старует и падает служба MS SQL Server.

Диагностика
В журналах сервера странное: CHECKDB прошел без ошибок для всех баз, но служба стартовать не хочет.

"000-00-00 00:00:00.00 spid8s      Recovery is complete. This is an informational message only. No user action is required.
2000-00-00 00:00:00.00 Server      SQL Server is terminating because of a system shutdown. This is an informational message only. No user action is required.
2000-00-00 00:00:00.00 spid37s     Service Broker manager has shut down.
2000-00-00 00:00:00.00 spid8s      .NET Framework runtime has been stopped.
2000-00-00 00:00:00.00 spid8s      SQL Server shutdown has been initiated
2000-00-00 00:00:00.00 spid8s      SQL Trace was stopped due to server shutdown. Trace ID = '1'. This is an informational message only; no user action is required.
2000-00-00 00:00:00.00 spid8s      Error: 17054, Severity: 16, State: 1.
2000-00-00 00:00:00.00 spid8s      The current event was not reported to the Windows Events log. Operating system error = (null). You may need to clear the Windows Events log if it is full"

В жуналах ОС видим Event 17311, источник MSSQLSERVER:
"SQL Server is terminating because of fatal exception c0000005. This error may be caused by an unhandled Win32 or C++ exception, or by an access violation encountered during exception handling. Check the SQL error log for any related stack dumps or messages. This exception forces SQL Server to shutdown. To recover from this error, restart the server (unless SQLAgent is configured to auto restart)."


Решение
Микрософт ничего интересного не предлагает: проверьте базу (это на мертвом сервере) или обратитесь в поддержку.

На самом деле всё оказалось просто: вовремя сбоя была повреждена одна из баз и при попытке её смонтировать MSSQL впадал в истерику (вспоминаем CHECKDB). Пострадавшая база была вычисленна с помощью последовательного блокирования доступа к файлам баз данных (прекратить доступ учетки сервера к файлам БД или, банально, их переименовать).

PS Как всегда, поврежденна оказалась мелкая и уже никому не нужная базуля.

DC Windows Server 2008 R2 BSOD c00002e2

Пациент: контроллер домена (КД) под управлением Windows Server 2008 R2.
Диагноз: BSOD c00002e2 :

на скрине так же можно наблюдать почему, в том числе, не стоит использовать руссифицированные ОС Microsoft.

Причина: локальная резеврная копия Active Directory протухла. Почитать журнал можно загрузив ОС в режиме Directory Services Restore Mode (DSRM).


Решение: переводим часы назад, на дату указанную в сроке действия теневой копии.

Примечание: в живой системе такое врят ли может возникнуть, но есть ситуации, когда надо замшелую мумию пошевелить.

Mikrotik, DDNS (no-ip-.com), Билайн l2tp

Скрипт для маршрутизатора Mikrotik, обновляющий данные на сервисе динамического DNS no-ip.com. Создано по мотивам блога дяди Freemana. Скрипт модифицирован для работы с провайдером Билайн по протоколу l2tp и статическими DNS-записями роутера (за роутером имя разрешается во внутренний адрес сети - нужно для корректной работы webdav по https).

:local inetinterface "l2tp-int";
:local noipuser "noipuser@mail.com";
:local noippass "password";
:local noiphost "myhost.no-ip.com";
:global currentIP;
:local newIP [/ip address get [find interface=$inetinterface] address];
:set $newIP (put [:pick $newIP 0 [:find $newIP "/"]]);
:log info message=("Detected IP: ".$newIP);
:if ($newIP != $currentIP) do={
:log info message=("No-IP: Current IP: ".$newIP." is not equal to previous IP: ".$currentIP.", update needed");
:log info message=("No-IP: Sending update for ".$noiphost);
/tool fetch url=($dnsurl.$currentIP."&hostname=".$noiphost) user=$noipuser password=$noippass mode=http keep-result=no;
:set $currentIP $newIP;
:log info message=("No-IP: Host ".$noiphost." updated on No-IP with IP ".$currentIP);
} else={
:log info message=("No-IP: Previous IP ".$currentIP." is equal to current IP: ".$newIP.", no update needed");
}

Сяокат. Две недели эксплуатации.

- Растянулся ручник.
- Слезла оконцовка тросика.
- При общей массе 94 кило батарейки хватает на 18км по сильно пересеченному городу.

Наблюдение: самые безотвественные участники дорожного движения - пешеходы. Не ясно как они головами не стукаются.

Что ломается В объективе Sony SELP-1650

Есть у компании Sony объектив SELP-1650, известный своей ненадежностью: обычно его заклинивает. Не официальный сервис за ремонт хочет не менее 5000р. Ломается вот это кольцо, особенно если процессу "помогли":



Отламываются маленькие кусочки, по сути несущие основную нагрузку, в трех местах:


Что бы починить объектив достаточно заменить это кольцо, ценой в 450р. Инструкций по разборке море

Linuxmint 18.1 KDE 64bit установка intel-graphics-update-tool

HP ProBook 430 G2

1) Изменить /etc/lsb-release

#DISTRIB_ID=LinuxMint
#DISTRIB_RELEASE=18.1
#DISTRIB_CODENAME=serena
#DISTRIB_DESCRIPTION="Linux Mint 18.1 Serena"
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04 LTS"

2) Поставить
packagekit
apt install packagekit

Это решит проблему "
GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.PackageKit was not provided by any .service files".

Yandex-browser (Linux) не проигрывает виде с YouTube



Проблема: Yandex-browser (Linux)  не проигрывает виде с YouTube (Ошибка. Повторите попытку позже. Идентификатор воспроизведения).

Решение:
1. Установить библиотеку chromium-codecs-ffmpeg-extra.
2. Скопировать файл /usr/lib/chromium-browser/libffmpeg.so в /opt/yandex/browser-beta/lib/libffmpeg.so.
3. Перезапусть браузер.

Code: sudo cp /usr/lib/chromium-browser/libffmpeg.so /opt/yandex/browser-beta/lib/libffmpeg.so